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1. Installation
Please start the installation file and follow the instructions. The CAD plugin will be installed on
your system. Select "eAssistant" or "TBK" during installation depending on the product. Once the
CAD plugin is installed, start SOLIDWORKS and open a new part. The Tools drop-down menu in
the SOLIDWORKS menu bar provides the entry "eAssistant" or "TBK".

In case the CAD plugin is not visible in the SOLIDWORKS Tools drop-down menu, you must enable
the eAssistant/TBK add-in application. Click Tools => Add-Ins from the SOLIDWORKS menu bar
and activate the eAssistant/TBK application.

2. Start
Click the Tools drop-down menu to use all functions of the CAD plugin in SOLIDWORKS.

3. Program Scope
Currently, the following features can be created in SOLIDWORKS based on the calculated
eAssistant/TBK data:
External and internal cylindrical and helical gears
Rack/pinion gear pairs
Straight, helical and spiral bevel gears
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Serrated shafts, splined shaft connections (shaft/hub)
Solid and hollow shafts with an unlimited number of cylindrical and conical shaft segments
Involute splines (shaft/hub)
as well:
Saving of calculation data in the 3D model
Placing manufacturing data of cylindrical gears, bevel gears and involute splines on
the manufacturing drawing
Cylindrical gears can be created directly on an existing part.
Bidirectional connection between eAssistant/TBK and SOLIDWORKS (shaft, gear, involute
spline profile as single design component) (from SOLIDWORKS 2008)
Accuracy/point distance for the tooth form can be defined in the options menu.
Tooth flanks as splines or alternatively as arcs for cylindrical gears and involute tooth
profiles possible

4. Menu
Calculation
Once the CAD plugin is started, all eAssistant/TBK calculation modules can be opened directly
through the Calculation menu in SOLIDWORKS.

Note on eAssistant: Please note that you need an eAssistant username and password to
start the calculation modules through the Calculation menu (see Settings ). Only the
free-of-charge modules can be used without the eAssistant access data.
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New Part
Based on the eAssistant/TBK calculation, the parts can be created directly in SOLIDWORKS by
clicking the menu item New part .

Complete a calculation using the eAssistant/TBK. Click on the button CAD => SOLIDWORKS output
in the top menu bar of the eAssistant/TBK. Confirm the message "Data for CAD was written
successfully." with the button "OK".

During the generation of involute gearings (cylindrical gears, single cylindrical gears, gear
racks, involute splines), the mean tooth thickness allowances and the mean tip diameter
allowances should be selected. The CAD model is then created with these allowances.
You can modify the allowances by opening the mask Tooth form in the respective gear
modules.
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Then click the menu item New part in the CAD plugin and select the corresponding element. Now
the 3D model is created.
User Data (applies only for eAssistant)
Click on the menu item Tools => eAssistant => Settings => User data to enter your eAssistant
username and your password. You need an account to use all eAssistant calculation modules.

In case you do not have an eAssistant account, please visit our web site www.eAssistant.eu to
register for a free test account. Click on the button Request access data to get to the eAssistant
web site as well. The account provides a time credit of five hours to test the eAssistant without
any charges or obligation. Are the five hours expired, the test account is deactivated automatically. If you want continue to use the eAssistant, you need to purchase an account. Decide
between hour packages or flat rates.

As soon as you entered your username and password into the window, you can start all eAssistant
calculation modules directly through the menu item Tools => eAssistant => Calculation without
logging in again. The eAssistant and SOLIDWORKS will be connected automatically.
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Activate the option "Save data permanent" to save your username and password and
to open all calculation modules immediately without entering username and password
again.

Options
Click the menu item Tools => eAssistant (TBK) => Settings => Options to adjust different settings
for cylindrical and bevel gears. Select spline or arcs (tangential) to connect the points.

You can, for example, define the distance between the points (accuracy) or the number of teeth
to be generated. Just activate the checkbox and enter the appropriate number of teeth.
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Language
Click the menu item Tools => eAssistant (TBK) => Settings => Language in order to change the
language. German and English are available. Restart SOLIDWORKS or the CAD plugin (by clicking
Tools Add-Ins ). The menu interface of the CAD plugin adapts itself automatically to the selected
language. The eAssistant/TBK calculation modules are started in the selected language as well.

Help
Click on the menu item Tools => eAssistant (TBK) => Help => eAssistant (TBK) help online to open
the eAssistant/TBK manual where you can find additional information on the eAssistant/TBK.
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5. Create a Shaft
Based on the eAssistant/TBK calculation, shafts with an unlimited number of cylindrical and
conical segments can be created as a 3D part. Click on the menu item Tools => eAssistant (TBK)
=> Calculation => Shaft to start the eAssistant/TBK module. Then make a shaft calculation. Click
on the button CAD => SOLIDWORKS export in the eAssistant/TBK module. Create the shaft by
clicking on the menu item Tools => eAssistant/TBK => New part => Shaft to create the shaft in
SOLIDWORKS.

You can also create a 2D sketch of a shaft in SOLIDWORKS and then import it to
eAssistant/TBK. Please see Section 12 for more information.

6. Create a Cylindrical Gear
Click on the menu item Tools => eAssistant (TBK) => Calculation => Gears => Cylindrical gear pair
in order to start the eAssistant/TBK calculation module. Then make a calculation. Click on the
button CAD => SOLIDWORKS export in the eAssistant/TBK module. Click on the menu item
Tools => eAssistant (TBK) => New part => Cylindrical gears => Cylindrical gear 1 or cylindrical gear
2, 3, 4 to create the cylindrical gear in SOLIDWORKS.
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7. Create a Gearing on an Existing Part
The eAssistant/TBK plugin provides a simple way to create a gearing directly on an existing part
(pinion shaft).

Make a gear calculation in the eAssistant/TBK. Click on the button CAD => SOLIDWORKS export .
Select a front face where you want to place the gearing. The face will then be highlighted. Select
the menu item Tools => eAssistant/TBK => New part => Cylindrical gears => Cylindrical gear 1 to
add the gearing to the existing part.
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When the dialog window for the "Runout configuration" appears, confirm with the "OK" button.
Please note that the tip circle diameter of the cylindrical gear gear and the diameter of
the selected shaft segment must have the same size.

8. Add Manufacturing Data to Engineering Drawing
With just one click, the design table with all manufacturing details can be placed on the
manufacturing drawing. Open a drawing in SOLIDWORKS. Select the menu item Tools =>
Assistant (TBK) => Manufacturing data => from selected view or from current calculation =>
Cylindrical gear 1 to create the table.

After installation of the CAD plugin, the file "Manufacturingdata.xml" appears in the program
directory. When calling the manufacturing data via the CAD plugin, a new folder is created in the
directory C:\User\[Username]\AppData\Roaming on Windows Vista or Windows 7. Various
templates (for example "ManufacturingdataBG.xml") for the design tables are saved in this folder
and only these xml files are used to configure the table. Based on these files, the design table can
be modified to your preferences.
Cylindrical gears, bevel gears and involute splines get a template as soon as you call the manufacturing data. For bevel gears, a distinction is made between straight/helical bevel gears and
spiral bevel gears. The appearance and size of that table are both individually configurable. Open
the xml file in a text editor and change the corresponding row, for example from visible="true"
into visible="false" to show or hide specific table rows. Save the xml file and place it to the
manufacturing drawing. In case you need more extensive customizations (font size, column width,
etc.) of the table, please ask for a more detailed description.
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If you delete the folder "eAssistant" in the user directory, the templates (xml files) are
deleted, too. To avoid this, please create a backup of the folder.

In case the path C:\User\[Username]\AppData\Roaming is not displayed, the folder options must
be adjusted. Open the folder options by clicking Start => Control panel => Folder options . Click
the View tab. Select "Show hidden files, folders, and drives" under "Hidden files and folders". Click
"OK" to save the new setting.
The modifications of the xml files will be lost after an update of the CAD plugin. You have
to subsequently maintain the modifications manually.

9. Open a Calculation of an Active Part
The calculation information is saved in the 3D model. The calculation, which belongs to the 3D
model, can be opened at any time throughout the entire design phase. If a component contains
several different calculation elements, it is possible to open the corresponding calculations.
To start the calculation, which belongs to the opened 3D model, click on the menu item Tools =>
eAssistant (TBK) => Calculation and select the corresponding calculation module. The following
dialog window appears. Click the "Yes" button and the eAssistant/TBK opens the calculation
module with all calculation values.

Even if there are several different gear calculations in one 3D model, you can open every
calculation file again. For the gear, for example, click on the feature tree on the left side in
SOLIDWORKS to select the corresponding cutout. Click on the menu item Tools => eAssistant
(TBK) => Calculation and then click on the calculation module.
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10. Add a Tool Runout to the 3D Model
For pinion shafts you can add a tool runout to the 3D model. For this purpose, you have to specify
a cutter radius. Select the menu item Tools => eAssistant (TBK) => Calculation => Gears =>
Cylindrical gear pair and run a cylindrical gear calculation. Click the button CAD => SOLIDWORKS
export . Choose a plane of the shaft in SOLIDWORKS and click the menu item Tools => eAssistant
(TBK) => New part => Cylindrical gears => Cylindrical gear 1 . The dialog window is opened.
Activate the option "Yes" for "Run-out at start" or "Run-out at end". Add a cutter radius and
confirm with "OK".

Now you can check if the tool runout collides with the following shaft segment, so that you can
correct it. If necessary, you can add a straight element by using the option "Offset".

11. Bidirectional Connection between eAssistant/TBK and SOLIDWORKS
The attractiveness of the CAD plugin is additionally enhanced by the bidirectional connection
between eAssistant/TBK and SOLIDWORKS. As changes are made to a calculation, the 3D model
can be updated (shafts, cylindrical gear, or involute spline profile/hub profile as single part).
Select the menu item Tools => eAssistant (TBK) => Calculation => Gears => Cylindrical gear pair
and make a cylindrical gear calculation. Click the button CAD => SOLIDWORKS export to transfer
the calculation values to SOLIDWORKS. Click the SOLIDWORKS menu item Tools => eAssistant
(TBK) => New part => Cylindrical gears => Cylindrical gear 1 to create the cylindrical gear.
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To make necessary changes on the CAD model, re-open the eAssistant/TBK module and modify
the calculation. Because the calculation information is saved to the CAD model, you can start the
eAssistant/TBK calculation by clicking Tools => eAssistant => Calculation => Gears => Cylindrical
gear pair . Confirm the following message "Shall the calculation of the active part be loaded?"
with the button "Yes" and the related calculation module starts.
For example, you can add a hole to gear 1. Click on the button CAD => SOLIDWORKS export .

Select the item "Extrusion2" from the integrated SOLIDWORKS feature tree. The area between
the teeth will then be highlighted.

Select Tools => eAssistant (TBK) => New part => Cylindrical gears => Cylindrical gear 1 and the
message "Should the component be adjusted to the current calculation?" appears.
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Click the "Yes" button and the CAD model is updated immediately and quickly adjusted to the
current calculation.

12. Create a Shaft in SOLIDWORKS and Import it into eAssistant/TBK
You can create a shaft directly in SOLIDWORKS and then import it into eAssistant/TBK. Solid and
hollow shafts with cylindrical and conical shaft segments are possible. To create a shaft as a
revolved part, use the CAD´s revolve features, the inner shaft geometry can be generated using
the revolved cut feature.
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To create a shaft as a revolved part, use the SOLIDWORKS Revolve Feature . Select the corresponding feature(s) from the FeatureManager design tree and import the shaft into
eAssistant/TBK by clicking the menu item Tools => eAssistant (TBK) => Calculation => Shafts .

The eAssistant/TBK shaft module opens and the shaft is loaded into the calculation module.
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We are looking for ideas, suggestions or criticism, so we would
like to know what you think.
You will always find a sympathetic ear, no matter what the problem is.

We appreciate your feedback.

GWJ Technology GmbH
Celler Strasse 67-69
38114 Braunschweig, Germany
Phone: +49 (0) 531 129 399-0
Fax: +49 (0) 531 129 399-29
Email: info@gwj.de

Visit our web site www.eAssistant.eu and www.tbksoft.com to find detailed
information or videos on the eAssistant/TBK software and the 3D CAD plugin.

Product information:
eAssistant and TBK are products of GWJ Technology GmbH.
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